Jump to content

brett.savage

Members
  • Content Count

    22
  • Joined

  • Last visited

Everything posted by brett.savage

  1. I am working on converting out existing powershell scripts to CWA Scripts and running into some issues. 1st I tried to use the "Execute Script" with Powershell (and PowerShell Bypass) and just copied the existing powershell script into the editor...it would just get hung up and I would have to reboot the PC to run another script against it. Then I tried downloading the script using the CWA Download URL option to a temp folder (which works) run the script with the same "Execute Script" with powershell and the bypass option, nothing. last thing i tried was to break apart the script (my test one was only a few lines) and use "shell Enhanced" with powershell.exe in front of it. every time I try this CMD "Invoking Script" will be stuck at running. All these things failed to work or run the simple tasks. The entire Script will run just fine if I run the .ps1 file from the test PCs. Example Script #Stopping Software Stop-Process -Name "software name" #Creating Temp Folder New-Item -Path "c:\" -Name "dbitemp" -ItemType "directory" #Downloading File Start-BitsTransfer -Source https://URLtoStoredFile/software.msi -Destination c:\dbitemp\software.msi #Installing the software "C:\dbitemp\software.msi /passive" | cmd sleep 60 #removing temp folder Remove-Item –path c:\dbitemp –recurse
  2. brett.savage

    Converting PowerShell Scripts to CWA Scripts

    We have clients who do not like change, and they have come to expect this application to always be running. Ill add the CWA option to start the program and remove it from the PS script. Thank you again for your assistance.
  3. brett.savage

    Converting PowerShell Scripts to CWA Scripts

    Added a -force after the stop process and that resolved the /v:on from stopping and from the hang with the on UI Edited the "excute PowerShell with Bypass" with the force and that seemed to resolve the issue with the CWA script as well. It runs almost perfectly, the only thing it does not do is open up the application, but that's not to much of a big deal. Thank you for your assistance on this matter. I will book mark the page and use this to see if any of my future converted scripts have any issues.
  4. brett.savage

    Converting PowerShell Scripts to CWA Scripts

    With UI: prompt for stopping process which stops script waiting for input, used A, script continued Created Folder Error on the download file line: "Start-BitsTransfer : The operation being requested was not performed because the user has not logged on to the network. The specified service does not exist." Failed install (no file) Deleted Folder Ran again with UI, this time putting the installer in place manually. prompt for stopping process which stops script waiting for input, used A, script continued failed on create folder (duh it already existed) Failed on download: same as before install worked deleted folder worked. With /v:on Failed to close out the app before install, but the rest of the steps went through no issues.
  5. brett.savage

    Converting PowerShell Scripts to CWA Scripts

    Yes I did, it worked fine with on the local PS1 script but still did not work with the CWA one.
  6. brett.savage

    Converting PowerShell Scripts to CWA Scripts

    Thank you for the reply. I did what you suggested, I converted the text to ANSI, I also tried manually typed it into CWA Script, to make sure it was in right. but it is still getting stuck at Invoke Script "Executing" inside CWA. I even tried making a CWA script that would just download the known working .ps1 and run it (with and with out excutionpolicy -bypass) and it still gets suck. So I think there is something wrong with my CWA itself.
  7. brett.savage

    WUA Version

    I am trying to figure out a good way to create a list/view of all our agents and their WUA Version. I know LT11 and the new patch manger stores the information in "computerpatchingstats" table under the "WUAVersion" column. I cannot seem to create a search or any other why to see the data listed other than looking inside the sql DB. Any suggestion or direction on how I can view this data?
  8. brett.savage

    What's inside your mystery box?

    We have several of the items you have. What I use on our list: Hard drive tests for WDC and Seagates Adobe PDF remover and installer Blue Screen View Bat file to clear printer Queues IP scanner (very helpful for finding printers and VoIP phones!!!) And we keep stock of a bunch of malware/virus cleaners for those pesky infections.
  9. brett.savage

    Labtech Patching - HRESULT: 0x8024001E

    It is an issue with Windows Update and how Microsoft broke it. Every time LT does an patch deployment it does a check for updates, the check for updates takes hours, therefore it goes outside the LT patch window and KB3172605 deployment is skipped. Not much LT can do, other than provide a script that would assist deploying KB3172605.
  10. brett.savage

    Labtech Patching - HRESULT: 0x8024001E

    I removed some of the personal links in it. You will need the links for the KB installers. No notes or logic checks. Copy of Deployment - KB3172605.zip
  11. brett.savage

    Labtech Patching - HRESULT: 0x8024001E

    To get past the HRESULT: 0X8024001E we created a script that updates WUA to 7.6.7601.23453. After we deployed that he have had 0 issues installing updates. Stop wuauserv service rename c:\windows\SoftwareDistribution folder start service download standalone installer for KB3172605 run quiet with no restart then let LT reboot the PC. I was able to push out this update during the day and let the clients choose when to reboot.
  12. Is there any way to decrease the amount of time it takes for an agent to check in when running scripts? We have several scripts that reboot the workstations which will cause the fast talk to stop so now our scripts are taking hours to run because of the 5 min between each cmd. I thought there was an option but I cannot seem to find it in LT11
  13. brett.savage

    Scripting - Decrease Agent Checkin time

    Thank you both.
  14. brett.savage

    Scripting - Decrease Agent Checkin time

    Not sure that will help, the reboots are not taking that long and the script is not timing out. It is just taking the 5 min for each cmd to send because the agent only checks in every 5 min. I am looking for a presistant fast talk or something along those lines.
  15. brett.savage

    LabTech 11 and Screenconnect Problem

    Interesting, support told me LT never auto set the names and it has always been a manual process. is a space considered special character? That is the only thing we have in our client names.
  16. brett.savage

    WUA Version

    I found a post talking about a data view creator built in to LT and was able to modify one of the existing ones and so I can display what i am looking for.
  17. brett.savage

    LabTech MySQL Server Crashes Every Few Weeks

    I was having a similar issue, they had me change the temp folder for mysql and it seems to be working great now.
  18. brett.savage

    Slack Notifier

    I too would be interested in knowing if this is has been worked any further.
  19. brett.savage

    Chocolatey II is in pre release testing

    Cubert, We seem to be having the same issue as aarontoops. We installed Chocolatey on the machines (using the cmd/PS script both ran locally and through LT cmd), We can run choco -v on the local machine and get a response, but when we try to run choco -v through the CMD tab inside LT it will say choco is not a valid command. I have rebooted the machines, I have confirmed the system variable PATH is there, I confirmed the c:\programdata\chocolatey folder is there. Any thoughts what we can run the CMD through the LT tab (or even the Chocolatey plugin)
  20. brett.savage

    LDAP Integration

    We use it at our office. Yes, the user has to log into CC using http (or https) which is not much of an issue with us because we no longer log into CC using the MYSQL port. Issues we have ran into is when a password is changed it can take up to a day for the password to "sync" with LT. There is no import from AD so you have to add the users needing access to LT. Make sure the usernames match.
  21. brett.savage

    TAPI - LabTech Alert

    We have our own SIP service and I was wondering if anyone has installed something like SIPTAPI (http://www.ipcom.at/en/telephony/siptapi/) and tried to setup the Alert that will call a user and read it to them, or does LabTech require a physical modem to be able to do this?
  22. brett.savage

    ESET Removal script?

    I have been running into an issue where I modified the built in script to include our ESET administration password (the one required to uninstall the product, http://docs.labtechsoftware.com/documentation/knowledgebase/article/6323) but the script will come back with an error 5004 "enter a valid password to continue uninstallation." The odd part is when I run the shell command listed in the script inside the command prompt tab it uninstalls fine. The only think of is our password contains special characters and that could be causing it to error out. Any suggestions? Script Line: "@InstallDir@callmsi.exe" /uninstall @ProductCode@ PASSWORD=#P@ssW0rd$! /quiet /norestart /L %ltsvcdir%\packages\eset\UninstallLog.txt Using ESET Endpoint AV v5
×