Jump to content

rshores

Members
  • Content Count

    13
  • Joined

  • Last visited

Everything posted by rshores

  1. rshores

    Parameters in new Report Center

    Hopefully, this one's pretty simple - I think I might be over-thinking it! I've built a report that shows some of the values associated with computers (from the 'v_xr_computers' table), and tying the 'Computers' table to v_processors, v_software, and the 'clients' table. Everything is working fine at this point. What I'm trying to do is limit the output of the report to a specific company with a parameter. I was able to create the parameter, and have it populated with all of the company names (not in alpha order... that's something else I'd like to figure out), but when I select one of the companies, I can't figure out where the SQL would go to only select the records matching that parameter. Hopefully, someone can point me in the right direction. Thanks in advance!
  2. rshores

    Parameters in new Report Center

    Figured it out... but I believe there's a bug in the Report Designer. My report is working fine, pulling an alphabetical list of clients into the parameter field, allowing me to select the client, and displaying accurate information in the report. I save the report (the design of the report, not the output) and go about my business. Next time I open Report Center, I have to reselect the data source for the parameter field. Every time. I reselect the data source, the report works fine. I save the report... when I next open it, the parameter field will not populate unless I go back into Designer and reselect the data source.
  3. rshores

    How to encode variable value at script run-time?

    Perfect - thanks!
  4. Hi, all! I'm trying to code a variable into an XML file to dynamically build a wireless network connection. Here's the format of the flat XML file: <?xml version="1.0"?> UCPM Wireless 535349442d4e616d65 SSID-Name ESS auto WPA2PSK AES false passPhrase false Password_Goes_Here I'd like to have a variable in their customer and site records so that I can build the XML dynamically, using something like the following: ######## %variable_from_location_to_allow_for_different_SSIDs% Does anyone know how I can encode the value in the populated %variable_from_location_to_allow_for_different_SSIDs% field at deployment time? It'll be a little more complicated than that, but I'm wondering if it'd just be easier to have 2 variables for each - normal value and hex code of normal value. Any ideas? Thx! Rick
  5. rshores

    Search doesn't return results

    My apologies if I'm posting this in the wrong place! I'm having what I hope is a stupid issue with a dataview. We're switching AV software on all of our clients, so I thought I'd pull a data view of all software, then be able to restrict it to only show records containing "ESET" (our old software). Here's a screencap of part of what should show up - this view has no searches, and should include everything: Next, I tried searching for the values "%ESET%", "ESET%", "*ESET*, and "ESET*" (all without quotes), and retrieved the following set of results (all search terms returned the same): I know that there's a search at the bottom of the tree which will show me all of the client computers with any sort of ESET on them, but I thoguht that this would be a good opportunity to try to learn how to use the dataviews (since I obviously have no clue!). I even tried taking the SQL from the AV/ESET search at the bottom of the tree and searching for the same values ('ESET NOD32 Antivirus', 'ESET Smart Security', 'ESET Endpoint%') in a manual search in a dataview, but still no dice. Does anyone have any insight on what I'm doing wrong? Thanks!
  6. rshores

    Search doesn't return results

    All I have access to is the LT client, not access to the server itself. Within what I'm able to see (searches, dataviews, etc) I can't find any place to enter the SQL query. I can see the SQL statement that builds the searches, but it's on a read-only popup, and I can't change the SQL statement, or write a new one there.
  7. rshores

    Search doesn't return results

    Curiouser and curiouser. When I search for "3CX" (with no quotes and no wildcards), I get 17 results - all of the machines across our whole enterprise that have the 3CX software installed, and all of the software on our server named "TYSV-3CX". The 3CX software packages that the search is picking up have a couple of different names: "3CX Phone System" and "3CXPhone for Windows" (showing that the search function apparently doesn't care too much about wildcard characters). Searching for "ESET" (with no quotes or wildcards) now returns all of the computers with ESET loaded, plus one computer with Carbonite that doesn't have ESET anywhere in the PC name (gotta take care of that Carbonite stuff now, huh?), and every install of "Microsoft OneDrive" and "Microsoft SkyDrive" (again, with no occurrences of ESET in the names of the PC's. I'm inclined to think that I've got the right idea with the searches, and that it just has some sort of issue with the search term "ESET" for some weird reason. Does that make sense? Thanks!
  8. rshores

    Permissions issue for reporting:

    Hi all, I'd like to run some ad-hoc reports to return simple information (show me clients where this program is this version, etc). I have written reports in CR and LogiReports for years, and am fairly confident that I'll be able to pull the right information, but... The "Field Name" field isn't populated in Report Manager. I'm not the SuperAdmin, I'm just a worker bee. We've dug into the permissions fairly deeply, but can't seem to find the right setting to give me the right permissions. I explicitly have "Read and Edit Reports" in my User Information - does anybody have any suggestions on where we should look for additional checkboxes that might need to be selected? Thanks!
  9. rshores

    Permissions issue for reporting:

    NaughtyNat82, if I could give you a gold star for today, I would! This functionality has opened up a world of new information gathering for us, and I really appreciate your help. We had no idea that we could use it this way.
  10. rshores

    Permissions issue for reporting:

    I might have figured this out (with your help).... if I go into an existing search (for all workstations, etc), and pull the additional information from an existing search, that may work. Thx!
  11. rshores

    Permissions issue for reporting:

    I like the sound of this, but I don't have rights in the Searches area either. Nothing happens when I right click (or double-click) at the root level, and when I right-click on an existing search, the 'Commands" menu is grayed out. Any idea where (in user permissions) I can ask for that to be enabled?
  12. rshores

    Permissions issue for reporting:

    I have been searching for this information. The canned reports that we've got aren't the most functional, and aren't giving me the information that I'm looking for, to wit: When Team Viewer was installed on our client machines, some of the passwords weren't set programatically, and are set to the same static value. We're trying to get away from that, but the only way that we've found to determine which client machines need to have the password update script run on them is to go into each machine and view the password field on the info tab, then run the password update script if necessary. This is pretty time consuming, and it seems to me that I could write an ad-hoc report in seconds that pulls client names and machine names to give me a list of machines that need the script run on them. I'll admit that part of this is that I just want to build better reports; I think we could do a better job of managing software versions, patches, etc with decent reports, and the canned ones that we've got aren't cutting it. Additionally, being able to generate software reports on demand for our clients would be helpful too.
×