Jump to content
Michael Priest

Discover Keys - Product Key Collector

Recommended Posts

Michael,

 

Is this plugin still in trial? or available for purchase? We have 3 SAM audits from Microsoft we have to do this month :-(

Share this post


Link to post
Share on other sites

I've made available an update for Discover Keys plugin which adds support for Recover Keys 9.0.

 

Availability

the update can be installed through my Plugin Installer : http://apps.michaelpriest.com.au/MPPluginInstaller/.

 

Changing to Recover Keys 9.0

 

1. Install the Plugin using the Plugin Installer listed above

2. Reload your LabTech Control Center.

3. Navigate to the LabTech Dashboard > Config > Integration > Discover Keys

4. Update Discovery method to "Recover Keys 9.0"

5. Enter your Recover Keys 9.0 License Key and save the settings

4. Issue Update Config command to Agents. (this will happen automatically over time, but to speed up the process you can manually trigger)

 

Regards,

Michael Priest

Share this post


Link to post
Share on other sites

Hey Michael,

 

I have just installed this to give it a try but it looks like its telling me I have no license and cannot use it

 

License type - not detected

License status - not detected.

 

I cannot get to any settings.

Share this post


Link to post
Share on other sites
Hey Michael,

 

I have just installed this to give it a try but it looks like its telling me I have no license and cannot use it

 

License type - not detected

License status - not detected.

 

I cannot get to any settings.

 

 

This has come good a number of hours later

Share this post


Link to post
Share on other sites

I seem to be having issues with the product. I have installed the plugin and it appears under Config / Integration / Discovery Keys. I have purchased the Enterprise version of Recovery Keys and have a valid license in hand. I have checked "Enable Discover Keys" / Selected Recover Keys 9.0 and input my serial number. When I save and exit "System Dashboard" the serial number field is blank. If I switch the dropdown to "Recovery Keys 8.0 the serial number appears.

 

When I check keys that it captured it says XXXX- Hidden in demo

 

Please help..

Share this post


Link to post
Share on other sites
Hey Michael,

 

I have just installed this to give it a try but it looks like its telling me I have no license and cannot use it

 

License type - not detected

License status - not detected.

 

I cannot get to any settings.

 

 

This has come good a number of hours later

 

Thanks for the update, i was going to say i could see it on my registration system, if these errors occur for others it might be worth-while restarting the LabTech Database Agent service.

Share this post


Link to post
Share on other sites
I seem to be having issues with the product. I have installed the plugin and it appears under Config / Integration / Discovery Keys. I have purchased the Enterprise version of Recovery Keys and have a valid license in hand. I have checked "Enable Discover Keys" / Selected Recover Keys 9.0 and input my serial number. When I save and exit "System Dashboard" the serial number field is blank. If I switch the dropdown to "Recovery Keys 8.0 the serial number appears.

 

When I check keys that it captured it says XXXX- Hidden in demo

 

Please help..

 

 

Mine version 9 key disappears as well if I look back into the plugin, but If i put it in, save it then exit it, its fine.

Share this post


Link to post
Share on other sites
Michael,

 

Has a price been set for this product yet?

 

Thanks!

 

Hi,

 

No price at yet, continue to keep using it in Trial mode, I've been extending all the trials.

Share this post


Link to post
Share on other sites

Hi All,

 

Version 1.0.0.9 is now available

 

Fixes

  • Resolved Issue with Inventory Process writing information to the Database on LabTech 10.5 Systems
  • Installation Process updated to allow installation on Fresh LabTech 10.5 Servers

 

 

Availability

the update can be installed through my Plugin Installer : http://apps.michaelpriest.com.au/MPPluginInstaller/.

 

Regards,

Michael Priest

Share this post


Link to post
Share on other sites

Can't pull any keys since upgrade from LabTech 10 to 10.5. Is there are a preferred process for removing and reinstalling Discover Keys? Which menu option is the definitive one to prompt a remote agent to immediately pull keys using DK?

Share this post


Link to post
Share on other sites

Hi All,

 

Identified an issue where 1.0.0.9 was being identified in the Plugin Manager as installed however the actual installed version is 1.0.0.8 as seen on the Tab's, i've fixed the installer to now correctly install the 1.0.0.9 version so you are able to re-run the installation process, I'll get a .10 release out in the coming days to fix any confusion there may be.

 

Cheers,

Michael

Share this post


Link to post
Share on other sites

We have been running this for near a couple of weeks now .......... sheer heaven not having to worry about that darn product keys script I can tell you.

Seems to have been literally a set and forget thing.

Our issues were that we were being bugged constantly with script failures and when we started looking at the data we found a lot of old redundant data, retired machines, duplicate keys etc. It was a mess. Some machines are initially deployed using one key, then activated later using another, the original key remains in the data.

 

So we decided to try Michael's plugin. We just simply copied our existing productkeys table to productkeys_old then truncated the original table.

Loaded up Michael's plugin and let it go. Unable to fault it at this point.

We are not yet using the Discover Keys software, but are seriously thinking about it to get all the extra license data.

 

One thing that's come up is that it might be nice to be able to build in exceptions somehow to stop gathering keys for certain products.

 

Thanks Michael, great job!

 

Regards Peter.

Share this post


Link to post
Share on other sites

I removed all product keys, ran update configs, resent software, resent everything. I'm still not populating any data into either your Product Keys tab for a machine or the Labtech Product Keys tab for my client. I am wondering what I should do or try to get this info. I also have it set to Recover Keys v9 and don't see the exe on an endpoint, so I'm wondering what the deal is.

 

I'm on version 105.244 for what it's worth. Everything seems to be setup correctly, but my product key tabs show no information.

Share this post


Link to post
Share on other sites

Hi Guys,

 

Looks like there was an issue with the plugin installer not correctly installing all components of this plugin, as a result some strange stuff happened, please re-run the installer and select Discover Keys to update and it will update and resolve the installation issues. Apologies for the inconvenience this may have caused. this problem was only introduced in the last 2 days.

Share this post


Link to post
Share on other sites

MPriest,

 

Very interested in checking this out, do you have a way yet to install this on Hosted Instances since the Plugin Installer won't allow the files on your download page?

Share this post


Link to post
Share on other sites

Hi Couri,

 

You are able to run the Plugin Installer from any machine and remotely connect and install to the LabTech to install.

 

Regards,

Michael Priest

Share this post


Link to post
Share on other sites

Michael,

 

All of my license keys are showing hidden in demo now. I have configured your plugin still shows active and the Recover Keys 9.0 license is valid. Any ideas?

Share this post


Link to post
Share on other sites

Typically if it is showing as in Demo the license key is incorrect or invalid.

 

you can confirm that the Key is being correctly transmitted down to the agent by checking the DiscoverKeys.ini located in

C:\Windows\LTSvc\Packages\MP\DiscoverKeys

 

Regards,

Michael Priest

Share this post


Link to post
Share on other sites

Was going to try and take a look at this. Appears it comes up that my license is expired after installing. Did I miss a step in retrieving a license for the trial?

 

-Thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×