Jump to content
Jagjeet

Reboot Schedule Plugin for LabTech

Recommended Posts

Hi Guys,

 

Here’s your “Reboot Schedule” plugin. You can reboot the machine at any schedule without worry.

Version: 1.7

Always update link:

https://sankalpit.com/reboot-schedule-plugin-for-labtech

Features:

1. Machines can be rebooted immediately.

2. You can reboot the machines anytime of current day.

3. Weekly reboot schedule can be made.

4. Machines can be rebooted particular days of Month.

5. You have an option to reboot machines on particular date.

6. Machine can be rebooted Last day of the Month.

7. You can save your notes as well.

Note: Only one procedure will be activated within 24 hours. In other words, plugin will send only one Reboot command on target machine thru reboot procedures. Reboot Schedule Tab only visible on Windows machines.

 

See the screenshots:

1.

 

 

 

 

 

2.

 

 

 

 

Don’t forget to provide me your kind feedback.

 

59ec9439416cf_Screenshot2015-08-2502_18_40.png.9851baf2ebd154d36f097be49776358a.png

 

Edited by Jagjeet

Share this post


Link to post
Share on other sites

Jagjeet ,

 

This is looks pretty good. Any future plans on adding options for Client or Location controls. Would be nice to have ability to schedule the reboots for an client or location....and with the ability to schedule based on machine type (workstation, laptop, server).

 

Also, I am missing the dataviews for the reboot history and schedules. Can you upload them. Thank you.

 

-jeff

Share this post


Link to post
Share on other sites

Hi Jeff,

 

I am already working on the same. Hopefully you will have the 2nd version of it sooner.

Here, the dataviews to download

 

Edited by Jagjeet

Share this post


Link to post
Share on other sites

this seemed to be working pretty great but randomly the reboot schedule tab has disappeared. Have you seen this happen?

Share this post


Link to post
Share on other sites

I know it was taking sometime to reload so i have updated the dll file. You can download the new version from here..

 

You need to update the plugin from plugin manager.

 

Edited by Jagjeet

Share this post


Link to post
Share on other sites
Guest SacaGeek

First of i want to thank you for this awesome plug-in, I'm still having issues with the days of the week sticking. So far only the days of the month will stick after I click "save information" When i choose all days for "Days of the week" and click save information then close the box, then open it up again the days of the week are cleared out.

 

Any thoughts?

 

Thanks again for your awesome Plug-in its a real treat! ^_^

Share this post


Link to post
Share on other sites

check whether the database table named `sankalp_rebootschedule` is exist or not?

if not, then re-import the plugin. Let me know if you are still facing the same issue.

Share this post


Link to post
Share on other sites
Guest SacaGeek

Thank you Jagjeet, for the quick response!

 

Ill give that shot, and keep you posted.

 

Thanks again JagJeet! your the best

Share this post


Link to post
Share on other sites
Guest SacaGeek
check whether the database table named `sankalp_rebootschedule` is exist or not?

if not, then re-import the plugin. Let me know if you are still facing the same issue.

 

Re-loading the plug-in worked!

 

the " sankalp_rebootschedule" was in the database, and we verified changes were being saved to the DB. It was just a matter of re-loading the Plug-in

 

Thank you so much JagJeet, I look forward to any further plug-ins develop!

Share this post


Link to post
Share on other sites
Guest SacaGeek

I have a very unique issue with the Scheduled reboot plug-in, I can configure the days, date, months with out any issue. How ever the only functioning part of the plug-in is Reboot once on:

what would prevent the plug-in from working?

 

I'v re-loaded the plugin, and updates

confirmed that the DB was seeing the changes being made.

Share this post


Link to post
Share on other sites

Hi,

 

I am not sure if you're using the right latest version of the plugin. Update the plugin with following dll.

 

if the issues is still present I don't mind to have screenshare on skype or via teamviewer.

Edited by Jagjeet

Share this post


Link to post
Share on other sites

Using this plugin is causing a 3-5 second lockup / freeze every 30 seconds. Took me a while to figure out that it was this plugin doing it.

Share this post


Link to post
Share on other sites

some how 100 data views were created for history and for schedule. Even though I have multiple servers scheduled and they appear on the 'scheduled' data view, nothing appears on the history data views. I will try to reload this new version.

Share this post


Link to post
Share on other sites

Same problem with the lockup hang freeze here. Every 30 seconds and the duration is based on internet speed. This is only when Super Admin permissions are enabled.

Share this post


Link to post
Share on other sites

Hi guys,

 

Thanks for your feedback on first version.. I have tried to resolve all the issues which are reported to me in 2nd version and hopefully you will have the latest version in upcoming week.

 

Thanks,

 

Jagjeet

Share this post


Link to post
Share on other sites

Hi Guys,

 

Today got some time to fix the following issues:

1. Freeze every 30 second.

2. Dataview duplication (new dataviews will be "Reboot Schedule Overview (7773)" and "Reboot Schedule History (7774)", you may delete the older dataviews.)

3. Remove most of the branding.

 

Also, it has nice looking console. You may download the new update here.

Update it by going to help-> Plugin Manager.

 

It won't override any schedule that you have already made.

 

let me know if you guys still facing any issue.

 

Edited by Jagjeet

Share this post


Link to post
Share on other sites

Feature request. In the dataviews "Reboot Schedule Overview" add a open computer link. The duplication has been fixed. I love the new console look. Thanks for all your work.

Share this post


Link to post
Share on other sites

Perhaps my green-ness is showing... I installed the plugin from my workstation, and restarted the database agent. I do not see the option to use this plugin, so I guess I am missing a step.

little help?

 

Thanks

Share this post


Link to post
Share on other sites

Having an issue. Some users see this tab just fine, others get a permissions issue when they open Labtech after installing this plugin, and the tab does not show. What needs to be done short of giving a user god mode to make this work?

 

Thanks,

Share this post


Link to post
Share on other sites

Not sure if it is just coincidence, but upon installing this plugin, all of my items in solution center showed out of date, and my Screen Connect integration was wiped :(

 

It's fixed now, but the outage and issues coincide exactly with the installation of this plugin. Has anyone else experienced anomalies immediately after installation of the latest plugin? I have removed it, but sure would like to have the function it provides. Just a little scared now after breaking the LT server for a short while.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×