Jump to content
Greg.Buerk

Introduction to Custom Tabs

Recommended Posts

I don't see a high option am I missing something...

 

 

Cant see anything on the main Configuration window either.

zx.PNG.3ea7d52cef9e6f800ac4d598d9648f38.PNG

Share this post


Link to post
Share on other sites
Ho, you've certainly put a lot of effort into...

 

Oh yes, btw, Casey or should I say Case? :lol:

 

My name is "Hoe" not "Ho", completely different meanings...

 

Ho: "Prostitute, Whore, Hooker, Tramp, Slut"

Hoe: "A tool with a flat blade attached approximately at a right angle to a long handle, used for weeding, cultivating, and gardening."

 

So I am officially a TOOL, please get it right. :lol:

 

HOE!

Share this post


Link to post
Share on other sites

So now you have to rub it in by posting a pic of my missus, right you're off my Xmas card list! :lol:

 

*One of her better photo's actually!

Share this post


Link to post
Share on other sites

You sure thats the updated plugin? I am showing it on myne.

 

 

 

I will rebuild and upload again in the morning if its not there for you.

59ec942d42c25_8-21-20138-09-06PM.png.47d2b254f0a77634b634d0ac2071b764.png

Share this post


Link to post
Share on other sites

Nope certainly latest, just tried downloading it again and reinstalling it but I still don't see that option. No rush on my account. :)

Share this post


Link to post
Share on other sites

Hi Guys me again! :lol:

 

I have a webpage tab at Client level which I would like to add a script button too, this script should run on just 1 machine at any site, what is the best way to achieve this?

 

Do I have to create an EDF to mark that machine out from the rest (it won't stand out in way or roles etc).

 

Or can I tell it easily to only run on master machines? In which case I just need to make sure each site has a suitable master.

 

Thanks

 

Hoe.

Share this post


Link to post
Share on other sites

Hoe, What is Take On?

 

How did you do the the following?

 

AUDIT-

Auto-Login (Displays any machines with Auto-Login enabled).

Hardware (Hardware Summary for Client).

Office (Office installations for Client).

Workstations (With OS and User info).

Servers (As above).

Share this post


Link to post
Share on other sites

Hi,

 

Take On is our form of Onboarding, it is in 4 stages (3 reboots) though you only ever run the top level, we keep it apart from Onboarding for a few reasons but that's another story, this is a screenshot from the Take On checklist as found on any Computer in our system...

 

 

By default the Started and Completed dates are ***TAKE ON NOT STARTED*** until changed by the script chain, this is just so it stands out, everything else is unticked (and not editable), update by the scripts after success confirmed.

 

AUTO-LOGIN:

On the Audit tab as shot earlier there is a EDF Text field...

 

Current Login Settings

 

This is NOT editable and it filled in by our standard Audit Script which looks at the usual Windows Keys (Default Username, Password, Domain and Auto Login Enabled keys) and records them here in this field (In most cases the password will not exist as Auto-Login is enabled by the SysInternals tool encrypting it), this is what the search it for, it effectively looks for anyone which has it listed as enabled in that Client \ Location.

 

However it is a little bit more funky than that, as if you look at one of my previous screenshots (Audit ones) you will see three settings...

 

Auto Login Username

Auto Login Password

Auto Login Domain

 

Which are editable and by default BLANK! (This is important).

 

I have one script "Enable \ Disable Auto-Login" which if run checks the Domain field, if there is anything in there then it Activates Auto-Login using the SysInternals tool, if it's blank it disables any existing Logins.

 

This allows us to disable it without having to delete the username \ password from the system and without having to rely on yet another checkbox. :)

 

===============

 

Hardware Summary is a simple search (DataList)...

 

Use this at client level:

Select DISTINCT Computers.ComputerID, Computers.Name as ComputerName, Computers.UserName, Computers.OS, v_Processors.`Name` as `CPU`, Computers.TotalMemory, v_extradataclients.`name` as `Client Name` from Computers, Clients, v_Processors, v_extradataclients Where Computers.ClientID = Clients.ClientID and v_Processors.ComputerID = Computers.ComputerID and v_extradataclients.ClientID = Computers.ClientID and ((v_extradataclients.`name` = '%clientname%'))

 

And this at location level:

Select DISTINCT Computers.ComputerID, Computers.Name as ComputerName, Computers.UserName, Computers.OS, v_Processors.`Name` as `CPU`, Computers.TotalMemory, v_extradatalocations.`name` as `Location Name` from Computers, Clients, v_Processors, v_extradatalocations Where Computers.ClientID = Clients.ClientID and v_Processors.ComputerID = Computers.ComputerID and v_extradatalocations.LocationID = Computers.LocationID and ((v_extradatalocations.`name` = '%locationname%'))

 

Ok I was just about to copy these out but it's a flawed plan, give me a bit I'll export what I can. :)

59ec942d4422d_takeon.PNG.0022b6139b5ada8802ddfe0913c2992e.PNG

Edited by Guest

Share this post


Link to post
Share on other sites

Ok the attached ZIP Includes the following for both Locations and Clients...

 

Hardware

Office

Servers

Workstations

 

There there might be another way to do the servers \ workstations option maybe even hardware through some of the built in lists but I haven't looked I had these searches already I just adjusted to suit.

 

 

 

Thanks

 

Hoe.

CustomTabs.zip

Share this post


Link to post
Share on other sites

trying to use the commands area to run a script on a computer, but I get an exception error when i click the button to execute the command. This is on a "computer" tab.

 

command configuration:

08.23.2013-02.13.png

 

error:

08.23.2013-02.13.png

Share this post


Link to post
Share on other sites

Updated plugin and added a few features. Have at it.

 

Big one. New replacement.

 

$SQL$$SelectStatement$

 

Example

$SQL$$Select ComputerID From Computers Where ClientID=%ClientID% and (Flags&16)=16$

would replace with the master computers id.

Share this post


Link to post
Share on other sites

Hi Greg,

 

Just like to confirm resolution of the webpage loading issue on 1.3.1 as well as the height box now appearing. :D

 

Thanks very much for this!

 

I don't know if it by design or not but if you look at the pic below (before and after DNS Tabs) in the split Webpage view (TOP) there is no option to show the address bar like on the main tabs, if possible if this could be added too that would be amazing.

 

 

Thanks again.

 

Hoe.

DNS-Test.png.83f48a756b3c78121868a585749eb4ed.png

Share this post


Link to post
Share on other sites

Hi Greg,

 

Also I seem to have found a bug, I wasn't sure how to use the statement...

 

$SQL$$Select ComputerID From Computers Where ClientID=%ClientID% and (Flags&16)=16$

 

When executing a script, I placed that exact statement in the "ComputerID" field in "Command Configuration", entered the script ID as per usual along with name and settings and saved, now if I try to go to that tab on any Client the tab errors completely...

 

 

Not seen this one before! The bigger problem is the field is blank when I try to clear it so I can't fix the tab! Fortunately I have a backup so I can export and import so it's not a major issue.

 

As I am impatient I am going to retry using the other field (which was what I was originally going to go for anyway), but I thought you might like to know.

 

***UPDATE***

I can't add any Command's anymore or this happens to the tab, in all cases I am adding a command Run Script using the script Number not GUID (I don't know an easy way to find that), in this particular case my Office Locations tab was missing some buttons from client level, I was simply copying these settings across so I know the settings are ok, but as soon as I add anything the tab is broken.

 

Thanks

 

Hoe.

office-error.PNG.ce8134db49072a25f7a9218ac904b540.PNG

Share this post


Link to post
Share on other sites

is there any way you could add a vertical scroll bar to the EDF list view? that way if you have too many EDF's on a custom tab, you can scroll down and view them all? currently they cut off if you have too many.

Share this post


Link to post
Share on other sites

Hi Greg,

 

I have been doing a lot of thinking regarding this and I would really like to move our documentation into LT now using EDF's and Custom Tabs, we will have some external notes still but minimal but things like DNS Provider login details we will configure on an Bulk Info tab or two, then each respective tab which load the webpage and show at the top the usernames and passwords, this will allow one place for entry and yet very easy access with just the info we need.

 

My question is this though, if I have a Tab which is Unique to a client \ location whereever can I create a tab which will appear on said level but only if said EDF Feild is not blank? I realise I this would almost certainly involve an Auto-Joined search if possbile, I just don't know if it's possible.

 

Once all this information is in place a script to report all this information to HTML or other will also be created and run daily (if changed) so the info is still accessible in the event of LT Server problems.

 

Thanks

 

Hoe.

Share this post


Link to post
Share on other sites

In the interest of keeping conversations 'on topic' and easier to find in the forums...Can I politely request that we please create new topics for different issues. This is just the 'Intro' topic!

 

Thanks. (Sorry, Forum Police Alert!!) lol

 

HAHA... He says at Post #101 ;)

Share this post


Link to post
Share on other sites
Noted, sorry officer it wasn't my fault, my wife was driving.

 

Yeah yeah Mr.!! Tell it to the judge!! Mwah-hahahahaaaaa

 

youre_nicked_final_640.jpg

 

 

Sent from my iPad using Tapatalk 2

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...