Jump to content
MrRat

MSP Accounts Plugin - Free

Recommended Posts

Mr Rat, 

I think one of your check boxes might not be working as expected. On the Service Account tab I had the "Include Excluded Locations" box unchecked and it still pushed the service account out to all locations. 

image.png.20831efbc8d2a12f271832386baf9db2.png

 

Share this post


Link to post
Share on other sites
16 hours ago, wdyoung said:

I had the "Include Excluded Locations" box unchecked and it still pushed the service account out

Oops, Thanks.

Share this post


Link to post
Share on other sites

I updated the plugin, and then updated a password for the service account, however, the service account password stored on the Location of the client never updated and a second line wasn't added. I'm just curious if anyone else has had this issue, and/or is there a way to force the plugin to update all the existing stored passwords?

Share this post


Link to post
Share on other sites

Hi MrRat

Great plugin.  I had a question on the network probe.  When we setup the probe we (as advised by LT support) use a local account for the LT service.  THe username and password are filled out automatically with the saved service accout.  when the password updates, would that then break the LT service that is now set to use the old password?

Share this post


Link to post
Share on other sites
On 1/3/2018 at 1:34 PM, dpltadmin said:

updated a password for the service account, however, the service account password stored on the Location of the client never updated 

eww.  i need to look into that

Share this post


Link to post
Share on other sites
7 minutes ago, Richie111 said:

When we setup the probe we (as advised by LT support) use a local account for the LT service.

yeah, i've heard that too, but I aint gonna do it.

 

Quote

 when the password updates, would that then break the LT service that is now set to use the old password?

yes;  and that would be why you never want to use a user account for a windows service.

 

Share this post


Link to post
Share on other sites

agreed on both :-)

But we had issues getting the probe to roll out machines and they said this was the solution.  Any thoughts would be greatly appreciated as I do not really like the solution.  we are in process of moving  from kaseya.

Share this post


Link to post
Share on other sites
34 minutes ago, Richie111 said:

But we had issues getting the probe to roll out machines and they said this was the solution

You don't want to use the probe to install.  You want this: 

 

that batch file of Darren's is sweet

 

Share this post


Link to post
Share on other sites

UPDATE Version 2.18.01.10
Download link in first post of this thread.

Bug fixes:
Local Service Account should obey Exclude Locations now.
Changing the password for the domain Service Account now works properly. (still have not added this functionality to local service account, yet)

 

  • Thanks 1

Share this post


Link to post
Share on other sites

Updated to plugin v2.18.01.10

Tested changing the Domain Service Account Password and it successfully updated in the location password tab. Thank you!

Looking forward to this working for the local service account as well.

Share this post


Link to post
Share on other sites
On 1/9/2018 at 3:41 PM, MrRat said:

 

that batch file of Darren's is sweet

 

Thank you.  This is something I wish the product does natively.  Kaseya was better at this part (not finding the machines it was bad at that but once it found them it was better at pushing them)

Share this post


Link to post
Share on other sites

Greetings,

I have uninstalled the plugin after removing the user accounts ect from the plugin options. Restarted the DB agent and I am still seeing lots of 4625 event id's in the security log on our servers. Where can I go to stop the msp account from making login attempts on the servers every minute? I see the 3 tables in sqlyog that pertain to this plugin. But I do not see where the process is that is making the login attempts.

image.png.7d784b99d28fc740d63d7c41b2c182b9.png

Share this post


Link to post
Share on other sites
23 minutes ago, Jett said:

Greetings,

I have uninstalled the plugin after removing the user accounts ect from the plugin options. Restarted the DB agent and I am still seeing lots of 4625 event id's in the security log on our servers. Where can I go to stop the msp account from making login attempts on the servers every minute? I see the 3 tables in sqlyog that pertain to this plugin. But I do not see where the process is that is making the login attempts.

image.png.7d784b99d28fc740d63d7c41b2c182b9.png

There is no process in the plugin that would login every minute.

If you created a system account then that would get assigned in a location under Deployment & Defaults and labtech may be trying to use that account to login.
Change the account used on the Deployment tab and delete the system account from the passwords tab.

 

Share this post


Link to post
Share on other sites

They are all gone it looks like at least on the deployment tab.

2018-02-13 17:53:51|Deletion of user succeeded. is what I see in the table information for most of all clients. From what I can tell, I can't see the service account anymore on any of the deployment & Defaults tabs.

Anywhere else I can look?

By the way, don't get me wrong. This plugin rocks. It just started having issues maintaining its passwords for us(most likely because of different domain password policies). The team also wanted to start monitoring 4625 Events id's . IT was pretty easy to identify when the emails I started getting during the test phase had 61-62 failed login attempts per hour every hour. THen we saw the service account name as the offender.

 

Share this post


Link to post
Share on other sites
1 hour ago, Jett said:

They are all gone it looks like at least on the deployment tab.

Have you restarted the Labtech Database Agent since you removed the plugin? Once that is done all code associated with the plugin will have been removed.

Besides the only time the plugin ever logs in is immediately after changing a password in order to test it. Something else is trying to use that account.

Share this post


Link to post
Share on other sites

Is ths plugin v12 safe or likely to be v12 safe? I like it's idea greatly, but as i'm on v12 and it wouldn't import, I'm unable to experience it directly.

 

Share this post


Link to post
Share on other sites
7 hours ago, WillG said:

Is ths plugin v12 safe or likely to be v12 safe? I like it's idea greatly, but as i'm on v12 and it wouldn't import, I'm unable to experience it directly.

 

I'm using it on v12.

 

Share this post


Link to post
Share on other sites
1 hour ago, WilliamG said:

I'm getting an error on missing dependencies trying to import

import?
v12 install procedure:

System > Solutions > Plugin Manager

top right - Advanced > Manage Plugins > Add Plugin

right click and Enable MSP Accounts

Close control center. On the Automate server restart the LabTech Database Agent. Open control center.

Share this post


Link to post
Share on other sites

Yup, per the readme, that's exactly what I did. Get the error message about being unable to load file or one of it's dependencies after it copies it to the temp folder. 

already verified full permissions on the dll, it's unblocked, the temp folder has full access, and the hash of the file matches on two different machines.

Share this post


Link to post
Share on other sites
3 minutes ago, WilliamG said:

Yup, per the readme, that's exactly what I did.

Is this a fresh install of v12 or an upgrade from 11?
i've seen this before with interface.dll version changes from a labtech upgrade.  i may need to recompile.

 

Share this post


Link to post
Share on other sites
On 3/23/2018 at 4:17 PM, dpltadmin said:

Would be really cool if this had an option to prevent special characters from being generated in the random password.

Settings tab Password Complexity set Symbols to 0

<edit>no. that wouldn't eliminate them completely would it. i suppose i could put an enable box in there.</edit>

 

 

Edited by MrRat

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×