Jump to content
Nemesis

Computer Replacement Audit Program (CRAP) - Update 3

Recommended Posts

Ever given a user a new machine and they confirmed all the software they need is available? How many followup tickets after that for things that they missed?

 

This is a standalone utility that you can use to compare the software list on two machines, and provide a report for the end user to review all the missing software.

Think: You: "I see you had Apple Sync on your old computer, do you use that?"

 

You can also use this as a pre-scan - You: "Before I order the new computer, can you mark on this list all the software you use?"

 

Comparison Usage:

0: Run the executable

1: Login to LabTech

2: Change the 'New Computer ID' if required (this will default to the computer your running it on)

3: Choose the 'Original Computer ID'

4: Choose Compare

5: Export to Excel (if desired)

 

Optional: Filter for missing software

1: Check the 'Show only missing software' and choose Compare

 

Pre-Scan usage:

Enter 'New Computer ID' and 'Original Computer ID' as the same id will show you a list of all the software on the machine.

 

  • Update 2:
    Added Service comparison
    Added Printer & Mapped printer comparison & paths
    Added mapped drive comparison & paths

 

  • Update 3:
    Added local user comparison
    Added local share comparison

 

Get it here:

(Wait for the DOWNLOAD option on top right)

http://bit.ly/1PPQmq8

 

AsuRh6m.png

 

MU1dbPv.png

Edited by Guest

Share this post


Link to post
Share on other sites

Nemsys ............ this is awesome. Quite likely one of THE most useful things I have used in quite a while.

 

Our guys will like this one. Thanks for sharing.

 

Regards Peter.

Share this post


Link to post
Share on other sites

After Reviewing with several at my company, we really like it. Main things we'd like to see added:

Printer Comparison

Services Comparison (preferably excluding default windows services)

 

One bug we came across is: When it autodetects the LT site, we are using https://mysite.whatever|https://24.220... and it has issues because of this. You could do a split on | and take the first address only and it would correct the issue.

 

Thanks!

Share this post


Link to post
Share on other sites

Update 1.1

Added Services comparison

Added Printers comparison

Added Mapped Drives comparison

 

Bug Fixed:

Addressed issue with | in the LabTech FQDN. Note: will default to the first named FQDN.

Share this post


Link to post
Share on other sites

This is awesome! We are going to use that!

 

- 1 error I found when I hit Export I get 2 times this error message:

 

If i select the whole table before exporting I get it 1 time

 

- If possible to export it to Excel instead of XML then open in excel with specific format, I think it would be more flexible to edit later.

 

Thank you

Untitled.jpg.96b42ff520374835b8de4d9338e2f5d8.jpg

Share this post


Link to post
Share on other sites

I didn't test those when I added the new features! I'll get an update out shortly.

Nemesis.

 

 

 

Should be fixed - get the latest build.

-Nemesis

Edited by Guest

Share this post


Link to post
Share on other sites
When there are no mapped drives it throws an error, is it supposed to do that?

 

Nope! I didnt test that condition. I'll get an update out shortly.

-Nemesis

 

**Update***

Fixed.

-Nemesis

Edited by Guest

Share this post


Link to post
Share on other sites
This is awesome! We are going to use that!

 

- 1 error I found when I hit Export I get 2 times this error message:

[attachment=0]Untitled.jpg[/attachment]

If i select the whole table before exporting I get it 1 time

 

- If possible to export it to Excel instead of XML then open in excel with specific format, I think it would be more flexible to edit later.

 

Thank you

 

 

1: Export error Should be fixed! Get the latest build!

2: If you look in the directory your executing from, the raw XML's should be there. (if that works....)

-Nemesis

Share this post


Link to post
Share on other sites

Update 2: (Added last week - forgot to update description)

Added Service comparison

Added Printer & Mapped printer comparison & paths

Added mapped drive comparison & paths

 

Update 3:

Added local user comparison

Added local share comparison

 

PM me if you find any issues.

-Nemesis

Share this post


Link to post
Share on other sites
Update 2: (Added last week - forgot to update description)

Added Service comparison

Added Printer & Mapped printer comparison & paths

Added mapped drive comparison & paths

 

Update 3:

Added local user comparison

Added local share comparison

 

PM me if you find any issues.

-Nemesis

 

Great updates.

Thank you again.

Share this post


Link to post
Share on other sites

Could some general pc info be included like model, bios, motherboard etc? Im considering making our techs use this to gather info before they put in quote requests for replacement workstations and then they can use it after to ensure the replacement goes smoothly, lifecycle mgmt lite sorta

Share this post


Link to post
Share on other sites
Awesome tool but WebRoot sees it as a virus ( I know its not ;) )

 

Ya, I have not figured out why yet. And it doesn't do it on all webroots - but Have seen the same issue, on my desktop Webroot doesnt see it, on my Laptop it does.

I think it may have to do with the fact I am using a self-signed certificate. (Guess I need to go purchase one...)

-Nemesis

Share this post


Link to post
Share on other sites
Awesome tool but WebRoot sees it as a virus ( I know its not ;) )

 

I've submitted to Webroot, and they have tested and cleared it for whitelisting! Scan again and it should be clean.

-Nemesis

Share this post


Link to post
Share on other sites

Looks nice, we don't have that sort of issue, but I just wanted to give you a HUGE kudos for the Acronym. CRAP << awesome, I'm giggling like I'm a six year old.

Share this post


Link to post
Share on other sites

Does this work with LT11? I just tried using it and its not letting me login. I'm able to login via the browser using same credentials but LCRAP fails to login

Can it be complex password used for the account?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×