Jump to content

Enabling .net 3.5?

Recommended Posts

Has anyone found a way to use Automate to enable .net 3 on windows 10?

I know this command when run from an elevated command prompt will work: fondue.exe /enable-feature:netfx3 /hide-ux:all

But that doesn't appear to work when run through Automate... At least not on Windows 10.


Full Scenario: I have an install script to install a program that requires .net 3, msi file bombs if it's not installed. Script works on machines that have .net 3 installed already. I can remote into those machines and manually run the command to enable (these are non-domain machines mind you) but can't seem to get the command to work through a script, or even through the command prompt for a single machine.

I have tried using the command in the script as a "Shell" line and as an "Execute Script - Powershell" line both with the same result of nothing.

Share this post

Link to post
Share on other sites

I've had problems doing this relying on the Internet as the source. Using Enable-WindowsOptionalFeature -Online -Featurename Netfx3 -Source <location to Windows CD SXS Folder> has worked successfully for me even running as SYSTEM from Labtech. The hard part is getting the source files down there.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now