Jump to content
Sign in to follow this  
vgarza

RMM Failure

Recommended Posts

Hello,

I remember last year I tried RMM tool to send commands through screenconnect(Control) and it worked.

I tried to make some things yesterday and it failed. this is what I am getting.

I do not know if this plugin is still working or if something changed.

We have an OnPremise server (2019.5(Patch 5)).

Thanks in advance.

 

PS C:\Users\vgarza> Invoke-RestMethod -Method Post -Uri 'https://sc.mydomain.com/App_Extensions/741ca49a-34ff-4b74-8a5e-beb2102b5646/Service.ashx/ExecuteCommand' -Body '["XXXXX", "XXX", "ipconfig", "10"]' -ContentType 'application/json'
Invoke-RestMethod :
        The resource cannot be found.
         body {font-family:"Verdana";font-weight:normal;font-size: .7em;color:black;}
         p {font-family:"Verdana";font-weight:normal;color:black;margin-top: -5px}
         b {font-family:"Verdana";font-weight:bold;color:black;margin-top: -5px}
         H1 { font-family:"Verdana";font-weight:normal;font-size:18pt;color:red }
         H2 { font-family:"Verdana";font-weight:normal;font-size:14pt;color:maroon }
         pre {font-family:"Consolas","Lucida Console",Monospace;font-size:11pt;margin:0;padding:0.5em;line-height:14pt}
         .marker {font-weight: bold; color: black;text-decoration: none;}
         .version {color: gray;}
         .error {margin-bottom: 10px;}
         .expandable { text-decoration:underline; font-weight:bold; color:navy; cursor:hand; }
         @media screen and (max-width: 639px) {
          pre { width: 440px; overflow: auto; white-space: pre-wrap; word-wrap: break-word; }
         }
         @media screen and (max-width: 479px) {
          pre { width: 280px; }
         }
            Server Error in '/' Application.
             The resource cannot be found.

             Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable.  Please review the following URL and make sure that it is spelled correctly.

             Requested URL: /App_Extensions/741ca49a-34ff-4b74-8a5e-beb2102b5646/Service.ashx/ExecuteCommand

At line:1 char:1
+ Invoke-RestMethod -Method Post -Uri 'https://sc.mydomain.com ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : InvalidOperation: (System.Net.HttpWebRequest:HttpWebRequest) [Invoke-RestMethod], WebException
    + FullyQualifiedErrorId : WebCmdletWebResponseException,Microsoft.PowerShell.Commands.InvokeRestMethodCommand
PS C:\Users\vgarza> 

 

Share this post


Link to post
Share on other sites

Make sure the extension on screen connect is up to date and enabled. After we updated screen connect the extension was disabled as the version we were running wasn't compatible with the latest version of CWC

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×