Jump to content
Ross Bowman

Browse Screenshot Access

Recommended Posts

I have a few users that are unable to "Browse Screenshot" for the computers they have access to, including their own, in Automate.  They are able to send the command, and I believe it takes the screenshot but they're not able to view the screenshots after the fact.  They were able to use this feature up until a few updates past and we've been chasing this access item for a while.

Where would this access be restricted? 

Share this post


Link to post
Share on other sites

Screenshots are located in the LTShare directory. Do they have access to these folders? Can they view the images outside of Labtech?

Share this post


Link to post
Share on other sites

Ross, are the permissions correct in L:\Screenshots?  We've had a ticket open for a long while that if the ConnectWise file service (forget it's actual name) is running as localsystem the permissions don't allow access to open the files. We have to run it as a local admin user in order for the file to inherit permissions from the directory.

Share this post


Link to post
Share on other sites

File system permissions definitely could be an issue, but no users would be able to access some/all screenshots for some/all computers if it was a filesystem permission issue.  If screenshots for any given computer are available for certain users (superadmins) but not other users (non-admins), it sounds like you are hitting a Known Issue @Ross Bowman.  The root issue is related to the CW File Service, but the problem is a table permission that is not granted to non-admins.  Try viewing a screenshot as an admin, and then have the user try again.  Sometimes (I assume if the table was recently referenced by the API endpoint) the offending query to the table is not triggered and the screenshot is accessible. After a period of time, it will begin failing again.

My ticket (#11947080 - "19.0.5.138> User Class other than SuperAdmin cannot browse screenshots") was escalated to Dev on June 12th.

 

 

Share this post


Link to post
Share on other sites

Thanks for your responses.  I think @DarrenWhite99 is correct with his assessment of my situation as my account as a super-admin can access them fine but these users having issues are non-admins.  I'll have to do some more testing to confirm but I'll probably be in the same boat opening a ticket to dev and referencing the existing one.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...