Jump to content
garryowens

Storagecraft ShadowControl Agent install

Recommended Posts

Hi, im a total newb to connectwise, and coming from Nable, am trying to do the following via a script:

ANY Windows Server 2003

Install https://downloads.storagecraft.com/_cmd/ShadowControl_Installer_3_8_en.msi & then subscribe using the command stccmd /subscribe ipaddress

Any Windows 2008 R2 or above server

install https://downloads.storagecraft.com/_shadowcontrol/ShadowControl_Installer_4.3_en.msi & then subscribe using the command stccmd /subscribe ipaddress

 

& just to catch any workstations that have shadow protect or imagemanager installed:

ANY agent with any OS that has any of the the process's "shadowcontrol-agent.exe" "spx_service.exe" "ImageManager.exe" "ShadowProtectSvc.exe" then also install https://downloads.storagecraft.com/_shadowcontrol/ShadowControl_Installer_4.3_en.msi & then subscribe using the command stccmd /subscribe ipaddress

is there any scrit already out there for deploying the shadowcontrol agent or any other suggestions?

 

Thanks!

Share this post


Link to post
Share on other sites

There's a StorageCraft plugin available in the Solutions Center.  Check that to see how many of your needs it covers.  You could certainly copy and modify what they've built if necessary.

Share this post


Link to post
Share on other sites

Hey Garry,

This is Justice Willis with StorageCraft. Reach out to me when you can at 1-801-871-2882 and we can get you questions taken care of. You can also email me at Justice.Willis@storagecraft.com 

 

Thanks and stay safe!

Share this post


Link to post
Share on other sites
Posted (edited)

Hey thanks, sorry i didn't see any notifications for the replies....

only just started on this and no matter what i do the MSI will not install through the script

heres the bones of it.. I can see the MSI download to temp and have tried SHELL as Admin & also EXECUTE as Admin but the installer doesnt run

tried different switches /QUIET, /QB,  /QN

if i log onto the machine run an elevated command prompt (with the /QN switch) and paste the install command it works fine.

so im wondering if theres some issue with MSI file? (ive tried the MSI downloaded from our shadow control appliance, and also direct from storagecrafts website... same results

I see the rest of the script seems to run as the files delete itself at the end

image.png.bb44ee62066f570b90f128ac6458ae72.png

also from the script log

The Script(388) was successful in the Then section.

Script:   Shadow Control Agent Deploy - Starting at Server Time: Monday, June 8, 2020 9:40:27 AM
IF    True         Time Taken:  0.9377793
L1    IF Software Installed    App (P1): StorageCraft ShadowControl   Jump (P2): :DoSubscribe     Time Taken:  0.9377793
L2    File Download URL (Forced)    URL (P1): 'https://downloads.storagecraft...'   LocalFile (P2): 'C:\temp\ShadowControl_Installe...'   Wait (P3): 0     Time Taken:  0.9395401
L3    Script Sleep    Seconds (P1): 10     Time Taken:  16.9996267
L4    Process Execute as Admin    File (P1): 'msiexec.exe /i c:\temp\ShadowC...'   Wait (P3): 0     Time Taken:  27.141732
L5    Script Note    Note (P1): :DoSubscribe     Time Taken:  35.1729175
L6    Shell as Admin         Time Taken:  35.1729175
L7    Resend Software         Time Taken:  37.2023934
L8    File Delete as Admin    FileName (P1): C:\temp\ShadowControl_Installer.msi     Time Taken:  57.2643926

6/8/2020 9:41:37 AM
ComputerID
Hidden_ComputerID

Edited by garryowens
llog

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...