Jump to content

Agent Deploy - Generate Installers with Tokens


Recommended Posts

@dekafox - Have you seen any false offline R&R's?

You could always delete the files located in C:\Support\Automate\. I originally left them there for reference. On the other hand, the actual CWAutomateDeploy.bat file is accessible by anyone on the domain if they know where to look (in SYSVOL share). The same argument could be said about placing the Agent.MSI in the NETLOGON share. In all of these cases, there's a privileged user already behind the firewall and authenticated against the domain controller. 

Link to post
Share on other sites

Today was the first day I was actually able to import it and start picking through how it works and testing the various bits.  I wanted to ask first about the R&Rs since to test the scenario I mentioned, I'd need to shut down a PC for a few days and if that was already a known quantity that would speed things up a bit in that part of testing things.

As for the security I just noted the previous person who had asked about it hadn't gotten a response, so I was considering what ways there were to raise the bar, if any, without actually breaking the GPO or switching to another method entirely.

Link to post
Share on other sites

I am seeing an error when running the Local Subnet agent deployment in some environments that I don't quite understand:

The script runs completely and gets caught here:

The Automate Server Parameter Was Not Entered or Inaccessible
Help: Get-Help Push-Automate -Full

 

BEGIN
{
    $ErrorActionPreference = "SilentlyContinue"
    $Verbose = If ($PSBoundParameters.Verbose -eq $True) { $True } Else { $False }
    Write-Verbose "Checking if Automate Server URL is active. Server entered: $($Server)"
    $AutomateURLTest = "https://$($Server)/LabTech/"
    Write-Verbose "$AutomateURLTest"
    Try {
        $TestURL = (New-Object Net.WebClient).DownloadString($AutomateURLTest)
        Write-Verbose "https://$($Server) is Active"
    }
    Catch {
        Write-Host "The Automate Server Parameter Was Not Entered or Inaccessible" -ForegroundColor Red
        Write-Host "Help: Get-Help Push-Automate -Full"
        Break
        }


This seems strange as when I look at the script I can't see why this would fail.  When I debug the script the variables it enters look fine.  What would be the best way to test this out before this breakpoint?

Edited by WConsulting
Link to post
Share on other sites

@WConsulting- It means that for whatever reason it cannot download the MSI from the server. It's typically either a locally installed AV blocking it, or a perimeter firewall not allowing it through. Use the URL and attempt to download directly from that computer, and the issue with often reveal itself. 

Link to post
Share on other sites

Good afternoon,

I used the Create GPO scripts which created the necessary GPO, however I have issues with my Windows 10 PC, that the install is not completing.  I see that the LTSVC folder is created however the install does not complete.

If I run the BAT file manually as administrator the install completes and updates.  

What can I do to properly run the GPO on all my Windows 10 PCs.

Thank you

Link to post
Share on other sites
2 hours ago, lberkowitz said:

Good afternoon,

I used the Create GPO scripts which created the necessary GPO, however I have issues with my Windows 10 PC, that the install is not completing.  I see that the LTSVC folder is created however the install does not complete.

If I run the BAT file manually as administrator the install completes and updates.  

What can I do to properly run the GPO on all my Windows 10 PCs.

Thank you

My issue is also only affecting Windows 10 devices as far as I can tell. I've deployed this GPO to servers at another customer without issue.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...