Jump to content
Vitaliy S.

[GA] Veeam Backup & Replication for LabTech

Recommended Posts

Hi Guys!

 

Thanks to everyone who have submitted feedback on the need for LabTech integration. The Veeam B&R plug-in for LabTech is now in public beta!

 

Bits

1. Go to [REMOVED BY MODERATOR]

2. Logon to web-site with your Veeam credentials

3. Additional password is labtech_beta

4. Download Veeam.LBP.Plugin.zip

 

Technical Support Procedure

For all technical issues, please open a support case via http://cp.veeam.com, select Veeam Backup & Replication as a product and put [LTbeta] tag in the subject. Once you do this, please update this topic with a case ID, so I could track it. Looking forward to your feedback!

 

Update (May 22nd)

Veeam Backup & Replication Plug-in for LabTech has just gone live and can be downloaded via this link

Edited by Guest

Share this post


Link to post
Share on other sites

Case ID 00622023

 

Discovered an issue with reporting. I only see one of the mentioned reports from the PDF and if I run it, it basically says it can't locate the *.RPT file.

 

Other than that, I am loving the plug-in so far, thanks Vitaliy S.

Share this post


Link to post
Share on other sites

Thanks! I will check this case with the dev team, and thanks for your positive feedback. On a side note, have you tried the integration with LT Backup Module (the new one)?

Share this post


Link to post
Share on other sites

We will be installing this tonight. Nice doco wtih it Vitaly, thanks.

Just a comment about integration with the existing New back up manager plugin, nice touch. Unfortunately though, that plugin is restricted to users with LabTech System Config permissions, so most of our guys cant use it.

Not such a big deal up till now as now we only have a few Back Exec machines in there, but may have some ArcServe ones coming in soon and now with Veeam using it too it will become more of an issue. At least Engineers will be able to see the Veeam information on the machines and reports.

 

We will give it a run for a couple of months and see how it goes.

Share this post


Link to post
Share on other sites

kreddish, while we are waiting for our support team to review your case, can you please tell me if you have these RPT files present in the LTShare reports subfolder?

Share this post


Link to post
Share on other sites

Hi there Vitaly, yes I'm sure it does. Most of the LabTech plugins do have that restriction.

 

Also, why restrict the DataViews to Super Admins? I think this information should be available to all users. The DataViews contain all the information useful to an Engineer, I guess they can see that data on the individual machines, but it's nice to get an overview of several clients sometimes.

 

I did have at least one data collection script fail on it's first run, however when I manually ran it it completed fine. I'll keep an on it and see if there are any more failures.

 

UpDate: I can get data from 1 report only, Last Backup Job Status. The other 2 dont seem to do anything, they dont even fail but just sit there with spinning circle.

We would like to see a Licensing DataView. We restrict permissions to the Dash Board, well at least to the configuration side of it anyway, so a lot of our guys are not able to see the licensing data at config > Integration > Veeam .......

 

Veeam seems to have disappeared out of our Backup Manager DashBoard now too.

 

So far ........... I'd say awesome job!

 

Regards Peter.

Share this post


Link to post
Share on other sites

Hi Peter,

 

Also, why restrict the DataViews to Super Admins? I think this information should be available to all users. The DataViews contain all the information useful to an Engineer, I guess they can see that data on the individual machines, but it's nice to get an overview of several clients sometimes.

As far as I remember this is a dataview enforcement. In order to retrieve and filter data by client you should be able to be in Super Admin group. Do you have any dataviews working without Super Admin requirement?

 

I did have at least one data collection script fail on it's first run, however when I manually ran it it completed fine. I'll keep an on it and see if there are any more failures.

Did it happen on the initial collection run? If you see this failure again, please let us know.

 

UpDate: I can get data from 1 report only, Last Backup Job Status. The other 2 dont seem to do anything, they dont even fail but just sit there with spinning circle.

Can you please open a support case and tell me your case ID? Do you try to trigger these reports across all backup servers or you're generating them based on some client's folder?

 

We would like to see a Licensing DataView. We restrict permissions to the Dash Board, well at least to the configuration side of it anyway, so a lot of our guys are not able to see the licensing data at config > Integration > Veeam .......

Got it, I think it would not be hard to do, will pass this to the dev team.

 

Veeam seems to have disappeared out of our Backup Manager DashBoard now too.

Hmm... can you send us the logs from the plugin for review?

 

So far ........... I'd say awesome job!

Thank you for your kind words, the plugin is in beta and I'm glad that you like it.

 

Thanks!

Share this post


Link to post
Share on other sites

All our DataViews are viewable by all users, no matter what permission they have. As far as I know this is normal.

 

The script failure did happen on the first run, I have not seen another since.

 

I will wait another day before opening a support case as I'm getting inconsistent results. I was just now able to open a Protected Machines report where I was unable to previously. I only have tried running reports against individual clients.

 

I will open a separate support case tomorrow for the Backup Management plugin issue and upload the logs through it.

 

Thanks, regards Peter.

Share this post


Link to post
Share on other sites
All our DataViews are viewable by all users, no matter what permission they have. As far as I know this is normal.

Ok, will double-check that again, as we definitely do not want to make our own restrictions :) Can you please give an example of the dataview that works with limited permissions?

Share this post


Link to post
Share on other sites
kreddish, while we are waiting for our support team to review your case, can you please tell me if you have these RPT files present in the LTShare reports subfolder?

 

Sorry for delay, been on jury duty. No - I do not have the RPT files and only show the single report in the Reporter area.

Share this post


Link to post
Share on other sites
No worries, what about LTShare folder? Is it mapped to "L" drive?

Yes - all my other reports are fine, simply do not have any RPT's for Veeam listed.

Share this post


Link to post
Share on other sites

Hi Vitaly. Only the Veeam DataViews have any sort of permission restrictions on them. All other data views are accessible by all our Users. That's as Lab Tech is out of the box.

 

I have opened Veeam Support Case # 00623525 in regards to Veeam data not showing in the Backup Management Dashboard.

 

It seems only 1 report is not going to run, the VM Backup Status report eventually just times out.

 

Regards Peter.

Share this post


Link to post
Share on other sites

We have a few clients still on Veeam 6.5 and they are getting the Data Collection script run against them, which fails to return any information, their servers also have the Veeam tabs but with incomplete data. If the Plug in only works on Veeam 7 then perhaps it should be confined to Veeam 7 installations.

 

Thanks.

Share this post


Link to post
Share on other sites
Only the Veeam DataViews have any sort of permission restrictions on them. All other data views are accessible by all our Users. That's as Lab Tech is out of the box.

Yes, we have already figured it out on the call with LabTech R&D team. Thanks for the heads up.

I have opened Veeam Support Case # 00623525 in regards to Veeam data not showing in the Backup Management Dashboard.

Our dev team would appreciate if we could see this live, so a remote WebEx session would be a preferable way to troubleshoot it (if you don't mind).

We have a few clients still on Veeam 6.5 and they are getting the Data Collection script run against them, which fails to return any information, their servers also have the Veeam tabs but with incomplete data. If the Plug in only works on Veeam 7 then perhaps it should be confined to Veeam 7 installations.

Yes, that's expected. As Veeam B&R v7 patch 4 is required by the plugin.

Share this post


Link to post
Share on other sites

I am having issues with my older Veeam clients as well. Almost looks like they have to be on Veeam 7 and the latest fix pack. I may be wrong.

Share this post


Link to post
Share on other sites

No, you're right. Judging from the table data, it only supports 7 patch 4. Connection_state is reporting this for other hosts: "This plugin supports only Veeam Backup & Replication v7 patch 4"

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×