Jump to content
Greg.Buerk

Duo Security Plugin

Recommended Posts

Just a fellow up on my issues.

 

The web portal loaded after an iis reset! (yay)

 

But the windows 10 issue in the control center is still there ( also one random windows 7 ).

 

The user is able to logon in the web portal or from other computers but when they enter their token at the control center Duo promp it always reject the token and close.

 

Anyone had that issue and found a resolution ?

Share this post


Link to post
Share on other sites
@Felix,

 

I think you may need to use LDAP proxy for that.

 

Off topic here, has anyone use DUO with Connectwise? Any pointer?

 

AuthAnvil is the only one that works with CW

Share this post


Link to post
Share on other sites

Hi Greg,

Would you by any chance has an instruction on how to enroll user on DUO side? I have added myself and my boss. But it has been awhile, now I have to re-enroll my boss and the rest of the team.

I could not find a place to enroll. I recall that there is a page/site that I just have to scan the QR code.

Share this post


Link to post
Share on other sites

lol, I just did the same thing to work on this plugin, forgot. Well go to the duo manager https://admin.duosecurity.com/

 

Then Click Users. If the users are there, you want to click the users name link and click on the Phone link. Then click Activate Duo Mobile, or Reactivate, then MAKE sure to send the install instruction via SMS. This will let them click and run it.

Share this post


Link to post
Share on other sites

Updated Plugin to support Regions other than the united states.

Also Fixed initial Loading Error and The DuoConfig getting updated to True when initial Configuration is applied.

Also when it does error on the test it will respond with an error message.

Will Only Test once , when its first config is saved

 

See Main Post for link to updated installer

Share this post


Link to post
Share on other sites

You should check the box maked Enable Web Control Center. Then after an save and an IIS Reset you will have a token box in the webpage

Share this post


Link to post
Share on other sites
Will this plugin continue to work with 10.5 and 11? I am on the fence on upgrade to 10.5

 

Hello - We implemented in LT 10 and it survived the upgrade to 10.5 without issue. Have been using it on 10.5 for 2 months.

Share this post


Link to post
Share on other sites

any chance of this ever being supported in the cloud version of LabTech? I have other 3rd party plugins, so I would have expected this to be supported?

Share this post


Link to post
Share on other sites
Will this plugin continue to work with 10.5 and 11? I am on the fence on upgrade to 10.5

 

Hello - We implemented in LT 10 and it survived the upgrade to 10.5 without issue. Have been using it on 10.5 for 2 months.

 

Thank you for the confirmation. :) I might pull the trigger to update on this Monday. *finger crossed*

Share this post


Link to post
Share on other sites
You should check the box maked Enable Web Control Center. Then after an save and an IIS Reset you will have a token box in the webpage

I just update to 10.5 I have the box checked. server restarted. The token field shown on the web portal. I can't login with the token generated. Any suggestion?

 

EDIT: Just tried again and it is working now. Thank you :)

EDIT2: I tried login with account that don't have DUO enable on web center. What should I put on the token field? I tried blank, but unable to login.

Share this post


Link to post
Share on other sites

I've had this working for a while now with the iphone app giving the code. Today I tried setting up with a YubiKey and although it works well in the desktop app, the web login always gives an error in Duo "Invalid passcode".

 

As the token issued by the YubiKey is much longer than the iPhone code, is it being truncated in the web interface perhaps?

Share this post


Link to post
Share on other sites

From what I've read on this forum, the plugin ONLY supports the token generated by the phone app. Other methods like yubikey, push, sms, are not supported.

Share this post


Link to post
Share on other sites

Not true, it's a text token from the iPhone and the Yubikey and it works in the Labtech app login and test. The iphone token is 6 digits, the Yubikey is much longer which is why I think it is possibly being truncated ONLY in the web interface.

Share this post


Link to post
Share on other sites

Ah, I see. Good to know that we can at least use ubikey with this plugin.

 

If the source code could be released, we could tell for sure what's going on w/ the web login and also improve the plugin by adding push notifications, etc.

Share this post


Link to post
Share on other sites

We might be moving to Auth Anvil anyway as I've heard they have a cloud based solution coming soon which is priced about the same as Duo. As Connectwise doesn't support Duo I'd rather have one 2FA method for both systems.

Share this post


Link to post
Share on other sites

Probably using the LDAP proxy. But unfortunately that's on-prem CW only =/

 

I'm sure you can use the Google Authenticator, but you don't have to.

Share this post


Link to post
Share on other sites

Well I had sales call a while back saying that the Cloud version of AuthAnvil was coming soon and it would support Connectwise and Labtech so as soon as it became available I tried it.

 

It doesn't work with Connectwise and it doesn't work with Labtech and this has been confirmed by support at all companies.

 

So thanks to AuthAnvil for wasting my time, I hope my experience prevents anyone else from similar frustrations and time wasting. I'm off now to sign up for a paid subscription for Duo Security as at least I know this will work.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×