Jump to content
Cubert

"Flu Shot" Antivirus & Malware plugin for LabTech

Recommended Posts

Flu Shot AV/AM Scanner & remover plugin

 

Looking for a no install, no service, no cost! AV solution or maybe just a "insta" scanner. No matter why you need it Squidworks now has it rapped up in a nice little plugin.

 

Have a peak at the new Flu Shot instant AV Scanner plugin.

Version 1.3.1 Now Available

http://www.squidworks.net/2014/09/labtech-flushot-antiviral-and-antimalware-plugin/

 

 

Cubert :geek:

logo_sm.png.0244f5d8463376b2059c1ec0272be8e6.png

Edited by Guest

Share this post


Link to post
Share on other sites

Cubert,

 

Just tried this out and it works very well!

 

One recommendation I would have is the ability to log what the scanner detects, and what it was able to remove. I've just ran this on a PC and it found 57 items and removed 45. Would be great to see what was removed in case it might have cleared away something that is legitimate, as well as to see what it could not remove that may still be on the PC and dodgy.

 

Fantastic tool, thanks again.

Share this post


Link to post
Share on other sites

Oh just wait and see... Maybe in the next 24 to 48 there will be version 1.1

 

In Version 1.1 you will be able to set up scanning parameters and see all the log results of each scan.

 

Very cool stuff in next release

Share this post


Link to post
Share on other sites

Cubert,

 

Just installed the new version, every time I go to the flushot tab I get an error saying "Error - > Object reference not set to an instance of an object"

 

Richard

Share this post


Link to post
Share on other sites
Cubert,

 

Just installed the new version, every time I go to the flushot tab I get an error saying "Error - > Object reference not set to an instance of an object"

 

Richard

 

 

Send me a screen shot

Share this post


Link to post
Share on other sites
Cubert,

 

Just installed the new version, every time I go to the flushot tab I get an error saying "Error - > Object reference not set to an instance of an object"

 

Richard

 

 

Send me a screen shot

 

 

Also did you shut down and restart the LT console?

Share this post


Link to post
Share on other sites

please confirm that you indeed have 3 database tables for plugin

 

 

plugin_sw_flushot_config

Plugin_sw_flushot_logs

plugin_sw_flushot_screenings

 

And when you click "OK" does plugin load? If so can you save a config?, can you click scan button and see scan launch in scripts tab?

Share this post


Link to post
Share on other sites

Plugin loads, script will run from the button, but all the drop down lists in the other tabs are blank.

 

I only have one of those tables, the plugin_sw_flushot_screenings but not the other two

Share this post


Link to post
Share on other sites

Ok thats the problem, missing tables

 

Lets remove the one table that does exist, Uninstall plugin, relaunch console, re add plugin, activate plugin, relaunch console, launch computer console and retest. Does 3 new tables get created?

 

If not post back here and I will send you the create table commands

Share this post


Link to post
Share on other sites

Just released Version 1.2 which has many bug fixes, enhanced scripts, better logs and we now include a help system in the plugin that will provide the information you seek.

 

Enjoy

 

Cubert :geek:

Share this post


Link to post
Share on other sites

Your the man Cubert! Thanks for this very useful. However we keep getting Error -> Object reference not set to an instance of an object when selecting the tab on the plugin. I guess we are also missing tables as well. What commands do we need to run to fix this? Ta!

Share this post


Link to post
Share on other sites

If I wanted to run this on say all PC's at one location, without having to go to the tab on each PC and set all the different options I want, is there any way to specify what the default settings should be if nothing is set? Or if I just right click the location and run the flushot script what will it default too?

 

Would be handy to be able to run this on multiple PC's at once should a Malware breakout occur.

 

Thanks again!

 

Richard

Share this post


Link to post
Share on other sites
Thanks Cubert, I followed your instructions this morning and all seems to be working again!

 

Not sure why that happens just that on an upgrade sometimes LabTech creates the tables correctly and some times it forgets.. Uninstall and reinstall of the plugin inside the plugin manager tends to fix the issues.

Share this post


Link to post
Share on other sites
If I wanted to run this on say all PC's at one location, without having to go to the tab on each PC and set all the different options I want, is there any way to specify what the default settings should be if nothing is set? Or if I just right click the location and run the flushot script what will it default too?

 

Would be handy to be able to run this on multiple PC's at once should a Malware breakout occur.

 

Thanks again!

 

Richard

 

Absolutely, I schedule the Give PC A FluShot on the Windows Desktop and Windows Laptop groups to run nightly with a Smart and Quarantine. Since it takes sometimes 1 to 2 hours I can see the results the next AM. I will be working on an master overview tab on the dashboard so you can get a global view of all issues found nightly and then report on that information. Maybe provide a way to export the data out as a report.

 

There is always something to be done..

Share this post


Link to post
Share on other sites

There is, but we all appreciate the effort!

 

How do you schedule on those groups with specific settings, or will it just run the smart scan and quarantine by default when you set a script to run at a group level? Or is this something that I wouldn't be able to do currently but can change in future with the overview tab?

 

I've ran this a fair bit today and am loving the results :D Really really useful plugin!

Share this post


Link to post
Share on other sites

By default if a PC has no config it gets one when script runs the first time against it. So not setting a config will cause a default config that is fairly safe(will not delete). But by editing PC's configs you can modify this action (scheduled or not).

 

 

Added script to the scheduled scripts tab of the groups you want this to run against.

 

Capture.JPG.1b0ae718db96bf2093b70ec549b5a8c9.JPG

Share this post


Link to post
Share on other sites
Thanks Cubert, I followed your instructions this morning and all seems to be working again!

 

Hi Richard, i tried to do this myself and it didnt work. Did you end up applying the tables manually?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...