Jump to content
Cubert

"Flu Shot" Antivirus & Malware plugin for LabTech

Recommended Posts

sorry but this application does not lend it's self easily to automation.

 

It requires a keystroke to run, it shuts down the desktop explorer and all browsers when run and opens a text doc afterwards. It doesn't seem to take any command line arguments so I do not see this as a viable option at this time. if you want to query the builder to see if there can be a silent option the I would look at the addition.

 

 

:ugeek:

Share this post


Link to post
Share on other sites
sorry but this application does not lend it's self easily to automation.

 

It requires a keystroke to run, it shuts down the desktop explorer and all browsers when run and opens a text doc afterwards. It doesn't seem to take any command line arguments so I do not see this as a viable option at this time. if you want to query the builder to see if there can be a silent option the I would look at the addition.

 

 

:ugeek:

 

I recently found that the executable is a sfx archive and can be extracted. I was able to edit the get.bat file and remove the pause that requires input as well as when it opens notepad. Something to look into.

Share this post


Link to post
Share on other sites
sorry but this application does not lend it's self easily to automation.

 

It requires a keystroke to run, it shuts down the desktop explorer and all browsers when run and opens a text doc afterwards. It doesn't seem to take any command line arguments so I do not see this as a viable option at this time. if you want to query the builder to see if there can be a silent option the I would look at the addition.

 

 

:ugeek:

 

I recently found that the executable is a sfx archive and can be extracted. I was able to edit the get.bat file and remove the pause that requires input as well as when it opens notepad. Something to look into.

 

Ah, see I didn't dig that deep into it.. I will that a look at the unzip and see what it is doing.

Share this post


Link to post
Share on other sites
So I'm Piloting Labtech v10 (I like to live on the edge) and none of the tables were automatically created. I was able to create the config and logs tables using the queries you posted but I still need to create the screenings table. Would you mind sharing that query? Also, had to move the scripts to the FluShot directory as they imported to the root of the scripts folder.

 

Thanks!

 

Forget all that noise... table wasn't creating because I had labtech using a directory other than LTShare... swapped that back and good to go.

Share this post


Link to post
Share on other sites

I ran into an interesting scenario. I am using the 1.3.3 version for reference. I clicked the Run Scan button from the tab on an agent. The agent is in a different timezone than I am and it scheduled the scan for one hour in the future. There is probably a way to make the script use the timezone of the requester instead of the timezone of the agent machine when scheduling.

Share this post


Link to post
Share on other sites
I ran into an interesting scenario. I am using the 1.3.3 version for reference. I clicked the Run Scan button from the tab on an agent. The agent is in a different timezone than I am and it scheduled the scan for one hour in the future. There is probably a way to make the script use the timezone of the requester instead of the timezone of the agent machine when scheduling.

 

 

Interesting, That would make since as the button schedules the scan based at the LT server time of "NOW" so if LT server NOW = 10:01 PM and system is -2 hours from LT server then agent time would be 8:01 PM and would wait 2 hours to execute.

 

That denotes a problem.. especially if we go the other route where agent is +2 hours. I would wonder if the script would even run?

 

So to fix this we will need to look at agent current time and schedule script for 1 minute in the future for that agent i suspect. I will look in to that.

 

 

Cubert

Share this post


Link to post
Share on other sites
Any chance of doing an "Audit" only function to list out issues for a potential client?

 

We can look into that yes..

Share this post


Link to post
Share on other sites

Cubert,

 

Another great plugin. Wish I'd found it earlier. Had just finished writing a script without outputs when I found this, so scrapped the script!

 

I'm getting this Output:

Emsisoft Commandline Scanner v. 10.0.0.5366

© 2003-2015 Emsisoft - http://www.emsisoft.com

You have no valid license required to start this application.

 

EDIT: Bollocks, just realised it's trying to run on a server, and you can't use the CLI on a server...

 

Love your work!

Stuart.

Share this post


Link to post
Share on other sites

Yeap, that is correct.

 

We may be looking at a rewrite that will include a improved interface and collection along with ability to license it for server and better updating of defs and such.

Share this post


Link to post
Share on other sites

Hey Thanks for this plugin its an awesome idea...

 

I am, however, having noobish issues and I know its my problem.

I must have missed a step as I am not seeing the flushot tabs anywhere.

I used plugin manager to bring in the dll

Restarted Console

activated it flushot in plugins

and I know how to do the next step of importing the xml with lt expansion importer but not quite sure what to import?

Am I just trying to import FluShot-Scripts-v1.3.3?

 

Still new to adding content like this

Share this post


Link to post
Share on other sites

Nevermind the third restart of console was the trick to get the tab showing.

Now im getting the errir- > object reference not set to an instance of an object

 

which I believe is covered already so I'll check

 

Thanks

Share this post


Link to post
Share on other sites

OK still fairly lost

There was mention to plugin tables but I"m not 100% sure where to look for those.

I get that object reference error still

Share this post


Link to post
Share on other sites

Nevermind I figured out what you meant. Hadn't done that yet.

Looks like that fixed that error!

Thanks a lot I'm a fan of your plugins!

Share this post


Link to post
Share on other sites

So I am a lot closer to successfully running these scripts but still having an issue.

Where is the 7za.exe supposed to come from? I downloaded 7zip and renamed it and put it in correct place on ltsv but doesn't seem to be working.

 

I'm getting 'no exe available, unzip must of failed'

I know I'm missing something

Share this post


Link to post
Share on other sites

I had some issues with this initially and it turned out the big file a2cmd.zip download was getting interrupted but there was still an empty or incomplete file a2cmd.zip which was enough to trigger the unzip action and causing FluShot to fail.

 

I created this Delete a2cmd.zip script you can use to delete that file then try to deploy again. Check the a2cmd.zip file, it should be pretty large... over 100MBs if I'm not mistaken.

 

Eventually it might be best to edit the FluShot scripts to check for the existence of a2cmd.zip and ensure it's about a certain file size or even better MD5 hash check against the file that is being downloaded.

 

Good luck, hope that helps.

 

-M

 

 

So I am a lot closer to successfully running these scripts but still having an issue.

Where is the 7za.exe supposed to come from? I downloaded 7zip and renamed it and put it in correct place on ltsv but doesn't seem to be working.

 

I'm getting 'no exe available, unzip must of failed'

I know I'm missing something

Delete a2cmd.zip

Share this post


Link to post
Share on other sites

That file is definitely there and is 166,000 kb ish so I think the whole file is transferring.

How did you put the 7za.exe in the correct folder? Iknow it's 7zip but did you just install then rename exe and put in the ltsv folder it needs to be in?

Share this post


Link to post
Share on other sites
That file is definitely there and is 166,000 kb ish so I think the whole file is transferring.

How did you put the 7za.exe in the correct folder? Iknow it's 7zip but did you just install then rename exe and put in the ltsv folder it needs to be in?

 

 

Correct I copy the 7zip exe to the LTsvc folder in scripts

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...